By using our website you agree that we use cookies. More information

| Agree

Support

How Do I Configure Publisher in Merlin Project for Exports?

Publishing in Merlin Project

Merlin Project integrates with a big range of applications in various ways. You can exchange data via:

  • Import,
  • Export,
  • Publish (automated and unattended export) and
  • AppleScript

If you like to automate export to provide project content to other users on a regular basis, you can use the publish feature and publishing actions. To configure your publishing actions:

Call from the menu File → Publish → Settings…

File - Publish - Settings

You can choose between three publishing options:

Select one of the three options or click the + symbol.

Publish to Calendar or Reminders

If you want to automate export to specific local or iCloud calendars select the Calendar option.
To automate export to specific local or iCloud reminder lists, select the Reminder option.

Read more here…

Note: You will need to allow access for Merlin Project to those apps in the macOS system preferences. In macOS open System Preferences > Security & Privacy > Privacy. Select Calendar or Reminders. Enable the checkbox for Merlin Project at the desired app.

Publish for Export

If you like to automate export to supported third party formats, you select the export option and configure the export publishing action. Following options are available:

Publish for Export

Name

Enter a name for this publishing action.

Exporter

Click Select….
In the export window, select an export format and configure it as desired.

Publish: Exporter

Account

Leave the account set to Local file to publish the exported data to a file on a path available over your Mac.

Publish: Account

File Name

Enter a name for the export file.

Folder

Define the folder in which you want to save the file. Click Choose…​ and select a folder on a path available over your Mac.

Our support recommends:

Select Local file for exports on your Mac, your internal or external disks, mounted network drives, iCloud Drive, Dropbox or other cloud solutions supporting Finder integration and appearing on your computer as Finder folders.

When Should Merlin Project Publish the Content?

When you define publisher actions, you can trigger them via File -> Publish -> Publish

Publish When Saving or Regularly

Select the publisher action as listed in File -> Publish -> Settings.
Switch to the publishing tab.

Publish

If you want to have the published content automatically updated each time you save your project, enable the checkbox next to Publish: When saving.

If you want regular publisher updates on some specific days and time points only, you can configure your publishing action accordingly and leave the file open.

Our support recommends:

Test Publishing at least once to make sure that your publishing action is set correctly and works as desired.

Special Cases

1. Do you want to upload the published content automatically?
If you have defined FTP or WebDAV Accounts in Merlin Project -> Preferences - Accounts, you can select an Account here, when you need to automatically upload the exported content on an FTP or WebDav Server.

Publish and automatic upload

Select Manage Accounts… to insert new accounts when appropriate.

2. Do you want to email the published content automatically?
If you have defined an SMTP Account in Merlin Project -> Preferences - Accounts, you can select the SMTP Account here when you need to automatically send the exported content as an e-Mail.

Publish and automatic e-mail sending

For e-mail dispatch, you must also provide the following mandatory information: From, To and Subject.

Configure - Publish and automatic email sending

From: Enter the sender and reply-to email adress for the recipients.
Subject: Enter the email subject text.
To: Select and filter for the resources who should receive the email as primary recipients.

Our support recommends:

Enter resources and their email adresses using any resources view or inspector.

BCC: Select and filter for the resources which should receive the email as BCC (blind carbon copy).
Message: Enter a message. The text will be positioned before the attached export file.

BCC and Message are optional.

Select Manage Accounts… to insert new accounts when appropriate.

The Merlin Project Magic on the Mac and iPad

Gantt chart, Kanban and mind map on Mac and iPad. Test now 30 days for free.