Support

Can Merlin Project Export Data to Excel?

Microsoft Excel

Yes, with Merlin Project you can export tabular project data to Excel or other applications like Numbers. Simply export the view as a text file (.csv) and open or import the file in Excel.

Excel accepts and shows text data in tabular form, so you can export Activities, Assignments, Resources or Attachments of your project.

You cannot export Netplan, Mindmap, Kanban or the Reports views.

Preparing a Merlin Project View for Export

Customize the view to show the columns you need to export into the spreadsheet. You can enable filters, limit the visible date range or choose to export in the details view if you need to limit the exported data.

A Merlin Project tabular view with Gantt

NOTE: A view with Gantt bars will export the values of the outline. If you need to export time phased information, you can switch the Row Type to 'Boxes'

A Merlin Project tabular view with Boxes

Export the visible Merlin Project Data

  • Call File > Export….
  • Select Text for the export format.
  • Select Semicolon for fields separator.
  • Click onto Export...
File > Export > Text

NOTE: Dates with time points are 'Text' for Excel. Should you need to keep such data as Date columns, you should disable the option Dates with times.


Our support recommends:

The default export options work fine with Numbers and you can always define the separator while importing the file into Excel, a csv with semicolons however, saves you time because Excel maps the data automatically to different columns.


Text Export Options

There is no universal standard for the csv file format. The output can vary depending on the application which saves or opens the csv file.

Project view

Per default your current view will be selected. Click the magnifying glass to select additional views if needed.
In this case, a folder will be created containing one csv text file for each selected view.

Separate fields with

csv files can use various separators. When exporting from Merlin Project you can choose one of the following: Tabs | Semicolon | Colon | Comma

Wrap fields with

The data in the csv file can be wrapped using various characters.
Choose one of the following: Single quotes | Double quotes

Line ends for

Select line ends according to the application opening the csv files and the operating system.
You may choose one of the following: Mac/Unix | Windows | Classic Mac

Encoding

The text data contained in the csv files can be saved using different encodings. The encoding to be selected depends on the application opening the csv files, the operating system and the system language.

You may choose one of the following: Western (Mac OS Roman) | Western (ISO Latin 1) | Western (ISO Latin 2) | Western (Windows Latin 1) | Western (Windows Latin 2) | Unicode (UTF-8) | Unicode (UTF-16)


Our support recommends:

Save the csv files in UTF-8 for a better import experience. When selecting the wrong encoding special characters such as €$§ or vowel modifiers (öäü etc.) maybe be off. If the application opening the csv file does not support UTF-8, you can repeat the export procedure from Merlin Project and select a supported Encoding.

File extension

You may choose one from the followings: csv | txt

Choose File extension

Default duration unit

This setting affects the following columns: Given Duration, Planned Duration, Expected Duration, Remaining Duration, Expected Elapsed Duration. When in need to perform further calculations in Excel, Numbers, etc with the content of such columns, you might want Merlin Project to recalculate duration values to one single unit.

For the calculation you can select one from the following units: Seconds | Minutes | Hours | Days | Weeks | Months | Quarters | Years

Leave this setting to None if you need the durations to remain in their visible number unit format.

With column titles

If you don't need the column titles and the data you export are self-explanatory you can disable them by export.

Outline levels

Enable or disable this option as you find more fitting. It indents the titles of the items in extra columns to match the hierarchy in the exported view.

Dates with times

If you don't need the time points in date columns, you can disable this option.

With resource assignments

Choose wether to include into the csv file the rows showing resource assignments. If this option is enabled, assignment rows will be included in the export even if they are currently collapsed.

With root activity

Choose wether to include into the csv file the row #0 which is the root activity of the project.

Merlin Project on the Mac and iPad

Your ideas, our magic – make projects easy! Test now 30 days for free.