Installation

Server:Install

Installing Merlin Server requires OS X 10.10.x Yosemite or later (recommended):

  • Download Merlin Server from our website

    Server:Install
  • Double-click the program icon and confirm the installation by right-clicking the button "Move to Applications Folder".

    Server:Install
  • Enter your administrator password.

    Server:Install
  • Merlin Server will install the following components automatically.

Remove

The default way to uninstall Merlin Server is via the menu option File > Uninstall. If you use this option, the following dialog will appear. Click the button Uninstall… to move Merlin Server and the project files used by Merlin Server to the trash.

Server:Install
Note If Merlin Server is still running, an error message will appear. First stop all Server services to uninstall Merlin Server or use force uninstall.
Server:Install

You perform the force uninstall by pressing and holding the »alt« key and then clicking the menu option_ File_ > Uninstall (force) …. Any active Merlin Server installation will then be uninstalled. Please note that this process disconnects all active users from the server.

Manual uninstall

The following paths contain files which are created by Merlin Server and which are required by it. If necessary, delete these files to completely uninstall Merlin Server.

Note Make backup copies of your files. We recommend using Time Machine or another back up system.
  • /Library/Application Support/net.projectwizards.MerlinServer

    This folder contains folders with documents and files for the individual services.

    Server:Library
  • /Library/LaunchDaemons/net.projectwizards.MerlinServer.Helper.plist

  • /Library/PrivilegedHelperTools/net.projectwizards.MerlinServer.Helper

  • /Library/LaunchDaemons/net.projectwizards.merlinserver.publishingservice.plist

  • /Library/LaunchDaemons/net.projectwizards.merlinserver.syncservice.plist

  • /Library/LaunchDaemons/net.projectwizards.merlinserver.webservice.plist

Following that, restart your computer.

Check Installation

You will find the »Check Installation« option under »File«. Click this option to check your Merlin Server installation and the required access rights.

Server:Check
Note Before doing this, stop Merlin Server. Please note that this process disconnects all active users from the server.

Checking the installation produces a report. This includes potential issues and, for instance, incorrect or missing permissions.

Server:Check Report
Note You can save the results of the check. In the report window, click »Save« and create a file with the results of the check. This file can be forwarded, if needed, to the Support team at ProjectWizards.
Server:Save check report

Overview of Merlin Server

Server:Overview

Merlin Server comprises a single window. It is divided into:

The sidebar (1)

This is where you find all the functions, which are divided into services and servers.

The main area (2)

This is where you will find all the options for controlling the functions previously selected in the sidebar (1).

Merlin Server Window Size

Server:Size

The server window is always displayed in its default size. To change the height and width of the window, drag the sides using your mouse.

Window Controls

The three small circular buttons on the upper left hand side of the window are used to close, minimize, and zoom in/zoom out of the program window.

Server:Buttons

Click the red button (x) to close Merlin Server. Click the Merlin Server icon in the dock or double-click the Merlin Server icon in the folder »Programs« to re-open Merlin Server.

Click the yellow button (-) to minimize the window to the dock. Click the window in the dock to expand it again.

Note You can perform the same step via the menu option »Window > Minimize« or using the keyboard shortcut cmd + M.

Click the green button (+) to expand the window to fit the screen. Click the green button again to return to the original window size.

Menus

Merlin Server features menu options and associated keyboard shortcuts. These are as follows.

Merlin Server

The menu option »Merlin Server« includes options provided by the operating system for all applications. It also includes options for uninstalling Merlin Server and checking the installation.

Server:Menu Merlin Server

The menu option »Merlin Server« includes the following menu options:

  • About Merlin Server

  • Services > Services Preferences

  • Hide Merlin Server

  • Hide Others

  • Show All

  • Uninstall…

  • Check Installation…

  • Quit Merlin Server [cmd + Q]

Merlin Server is ended but all activated services remain active.

File

The menu option »File« includes an option which closes Merlin Server, although all activated services remain active.

Server:Menu File
  • Close [cmd + W]

Edit

The menu option »Edit« includes options provided by the operating system.

Server:Menu Edit
  • Undo

  • Redo

  • Cut

  • Copy

  • Insert *.Paste and Match Style

  • Delete

  • Select All

  • Find

  • Spelling and Grammar

  • Substitutions

  • Transformations

  • Speech

  • Start Dictation

  • Emoji & Symbols

Note Several options are grayed out. When selecting text areas or text fields, the majority of options then become available.

View

The menu option »View« includes options that allow you to display individual areas in Merlin Server. The associated keyboard shortcuts make it easier to select the individual areas quickly.

Server:Menu view

Services

  • Sync [cmd + 1]

    • Documents [cmd + 2]

    • Tenants [cmd + 3]

    • Accounts [cmd + 4]

  • Web [cmd + 5]

  • Publish [cmd + 6]

Server

  • Certificates [cmd + 7]

  • Licenses [cmd + 8]

Window

The menu option »Window« manages the open program windows.

  • Minimize [cmd + M]

  • Bring All to Front

  • √ Merlin Server

Help

The menu option »Help« includes the integrated search function to search the individual menu options and this Merlin Server help guide as well as the option to create a Support Profile. Our Support team may ask you for your Support Profile for troubleshooting.

  • Search

  • Merlin Server Help [cmd + ?]

  • Create Support Profile…

Sync Service

The sync service is responsible for synchronization and is required for the services »Publishing« and »Web« in Merlin Server.

Server:Sync Selection

The sync service in Merlin Server has the following information and options:

  • On/Off switch

  • Status and link

  • Last access with log

  • Connected users

  • IP-Addresses

  • Port

  • Hostname

  • Master Password

Switching On/Off

To activate the sync service, click the Off button or move the slider to the right using your mouse.

Merlin Server will then start the sync service in a few moments. The slider will stay in the On position and the status will change from Stopped to Available.

Note If you already used Merlin Server on the Mac with multiple services at the same time, you will be notified to restart all the services simultaneously.
Server:Sync On All

Status

The status indicator tells you about the availability of the sync service and its current availability (on the local network or on the internet).

Server:Sync Off

To make changes to the service settings, the setting must be stopped.

Server:Sync One Local

The service is enabled and available locally.

Note If do not enter forwarding rules on your router for the Merlin Server port, by default the server will only make its services available on the local network.
Server:Sync On Internet

The »Link« option has two functions.

Server: Link
  • Open in

  • Copy for

Clicking the Open in option opens Merlin Project on your Mac and displays the window Merlin Server - Documents.

With the Copy for option, you create a clipboard link to the current service path. You can paste this link into any program, such as Mail, TextEdit or similar, using the option Edit > Paste or cmd + V and share it with other participants.

Server: Link in TextEdit

Last Access

The option Last access shows a user’s most recent activity in the sync service.

Please refer to the Console.app supplied with OS X for further information on the sync service. To do this, click the Show Log button.

Console App: Access Log

The Console.app includes a variety of information on the sync service. You can select this in the sidebar. Access attempts are saved in »access.log« files.

Console App: Error Log
Note Errors are logged in »access.log« files.

Connected Users

Current service use is displayed here depending on the number of users in the license purchased for Merlin Server. By default, 5 users are supported simultaneously in Merlin Server using the smallest license.

Users: Server
Note The number of open files is irrelevant. It concerns the individual users who are connected simultaneously to Merlin Server. Please refer to your Merlin Service license for the maximum number of users.

IP Addresses

Note Switch the sync service off to make changes to the following option.

The option »IP-Addresses« lets you set the IP addresses which Merlin Server should use. The IP addresses are active addresses from the network services active on your Mac.

This option can be helpful when using VPN, Wi-Fi, Ethernet, and other network services.

All active addresses are used by default. Select or deselect the target IP address by using the drop-down menu.

Note The active network services can be found in OS X by going to System Preferences > Network.

Port

Note Switch the Web service off to make changes to the following option.

Merlin Server uses the Port 7190 for the sync service. If the port is already used in your company, you can set another port for the sync service.

Hostname

Note Switch the sync service off to make changes to the following option.

The hostname of the sync service is adopted automatically from the router or no explicit hostname is used. If you want to use your own hostname, click the Edit button.

Sync: Hostname

Then select the option »Use hostname« and enter an IP address or a dedicated hostname in the field.

Master Password

Note Switch the sync service off to make changes to the following option.
Sync: Master Password

The »Master Password« protects you from unauthorized third-party access. Should you choose to setup Merlin Server on more than one macs, and want to access from another mac this Merlin Server sync service, this is the password you need to enter there when selecting this data source.

Syncing Documents

The sync service is responsible for synchronizing and makes documents available to users.

Server:Sync Documents

Publish new documents

There are several ways to add documents to the sync service.

Plus Icon

Click the plus icon on the bottom left.

Server:Documents Folder

You can choose between two options:

  • Publish Documents…​

  • New Folder

Click »Publish Documents…« and then on one or more documents supported by Merlin Server.

Server:Sync New Documents

To publish the selection, click the »Publish« button.

Drag & Drop

Server:Sync New Documents Drag&Drop

Drag one or more documents into the window field.

When you start the sync service, these documents will be available to all users with appropriate document permissions.

Note You can add documents while the sync service is running, so there is no need to switch it off.

Create New Folder

You can manage documents in Merlin Server using folders. Create a new folder by clicking the plus icon and selecting the option »New Folder«.

Server:Sync New Folder

Name the new folder and then populate the folder with documents.

Delete Documents/Folders

Select one or more documents from the list and either press the delete key on your keyboard or click the minus icon on the bottom left.

Server:Sync Documents

Confirm the deletion process.

Note You can delete documents while the sync service is running, so there is no need to switch it off.

Remote management password

Server:Sync Remote Password

If you want to grant the permission to Merlin Project or Merlin Project Go users of sharing and managing documents of this server, you need to enter a remote management password. Just click the »Remote Management Password« button on the bottom right. and share the newly created remote management password with those users.

To change the remote management password, follow the same steps as for creating a new password.

Server:Sync Remote Password

Right-click a document in the list. You can choose between two options:

  • Open link in

  • Copy link for

The option Open link in lets you open the document in Merlin Project.

The option Copy link for lets you create a link to the document in the clipboard. Open any text program (such as Mail or TextEdit) to paste the link into it using File > Paste or cmd + V.

Publishing

You can access the publishing service via the following options:

Server:Publishing
  • On/Off switch

  • Status

  • Next attempt

  • Last success with log

  • Data source

Note Publishing requires an active sync service as well as at least one configured publishing service. For further information, please see "Merlin Server Publishing Services".

Switching On/Off

To activate the publishing function, click the Off button or move the slider to the right using your mouse.

Server:Publish To

Merlin Server will start publishing in a few seconds. The slider will stay in the On position and the status will change from Stopped to Running.

Status

The status tells you about the activity of the service. Green means the service is active.

Next attempt

Next attempt shows you the time when Merlin Server will republish the data.

The Show Log button opens the console app and the logs saved within it concerning the publishing service.

Server:Publish To

Last Success

Last success shows you the time when Merlin Server last successfully published the data.

Data Source

This option tells you whether the service on the Merlin Server used by you or another Merlin Server installation is acting as the »data source«.

Click the Edit button to use a different data source.

Server:Data Source
Note Should you need to select another sync service from another Merlin Server, click Sync service from a different Merlin Server installation and enter the URL and master password of that Merlin Server.

Publishing Accounts

The publishing function requires at least one configured account. On the sidebar click Accounts beneath Publishing.

Server:Publishing service

Merlin Server offers three different accounts for publishing:

  • FTP

  • SMTP

  • WebDAV

Server:Publishing service

Click the plus icon to add a new publishing account or click the minus icon to delete the selected account.

FTP Account

Click the plus icon and then click FTP from the down-down menu.

Server:Publishing service FTP

Doing so creates a new FTP account for publishing.

The following configuration settings are available for the FTP account:

  • Name

  • Server Address

  • Port

  • Path

  • User name

  • Password

  • Encryption

The »Connection status« option tells you whether you are connected to the FTP server. Check the settings for any input errors, etc.

SMTP

Click the plus icon and then click SMTP from the down-down menu.

Server:Publishing service SMTP

Doing so creates a new SMTP account for publishing.

The following configuration settings are available for the SMTP account:

  • Name

  • Server Address

  • Port

  • User name

  • Password

The »Connection status« option tells you whether you are connected to the SMTP server. Check the settings for any input errors, etc.

WebDAV

Click the plus icon and then click WebDAV from the down-down menu.

Server:Publishing service WebDAV

Doing so creates a new WebDAV account for publishing.

The following configuration settings are available for the WebDAV account:

  • Name

  • Server Address

  • Port

  • Path

  • User name

  • Password

  • Encryption

The »Connection status« option tells you whether you are connected to the WebDAV server. Check the settings for any input errors, etc.

Web Service

The Web service allows Merlin Server documents to be accessed via a Web browser.

Server:Web
Note The Web service requires an active sync account.

The Web service in Merlin Server has the following information and options:

  • On/Off switch

  • Status and link

  • Last access with log

  • Connected users

  • IP-Addresses

  • Port

  • Hostname

  • Data Source

Switching On/Off

To activate the Web service, click the Off button or move the slider to the right using your mouse.

Merlin Server will then start the Web service in a few moments. The slider will stay in the On position and the status will change from Stopped to Available.

Status

The status indicator tells you about the availability of the Web service and its current availability (on the local network or on the internet).

Server:Web Off

To make changes to the service settings, the setting must be stopped.

Server:Web On Locally

The service is enabled and available locally.

Note If do not enter forwarding rules on your router for the Merlin Server port, by default the server will only make its services available on the local network.
Server:Web On Internet

The »Link« option has two functions.

Server: Web Link
  • Open in

  • Copy for

Open in

The Open in opens your default Web browser and you can see the document window in your browser.

Note If no certificate exists for the server, the warning shown will be displayed in your Web browser.
Server: Web Certificate

Non password-protected documents can be viewed directly in the Web browser. Password-protected documents require you to log in, and are marked with an appropriate icon.

Server: Web Login

Click Login to view the password-protected documents. Log in to the document using the user’s name and password.

Server: Web Login
Note Hidden documents can be made visible only once you have logged in as a resource using the associated password.
Copy for

With the Copy for option, you create a clipboard link to the current Web service path. You can paste this link into any program, such as Mail, TextEdit or similar, using the option Edit > Paste or cmd + V and share it with other participants.

Server: Link in TextEdit

Last Access

The option Last access shows a user’s most recent activity in the Web service.

Please refer to the Console.app supplied with OS X for further information on the Web service. To do this, click the Show Log button.

Console App: Access Log

The Console.app includes a variety of information on the Web service. You can select these in the sidebar. Access attempts are saved in »access.log« files.

Console App: Error Log
Note Errors are logged in »access.log« files.

Connected Users

Current service use is displayed here depending on the number of users in the license purchased for Merlin Server. By default, 5 users are supported simultaneously in Merlin Server using the smallest license.

Users: Server
Note The number of open files is irrelevant. It concerns the individual users who are connected simultaneously to Merlin Server. Please refer to your Merlin Service license for the maximum number of users.

IP Addresses

Note Switch the Web service off to make changes to the following option.

The option »IP-Addresses« lets you set the IP addresses which Merlin Server should use. The IP addresses are active addresses from the network services active on your Mac.

This option can be helpful when using VPN, Wi-Fi, Ethernet, and other network services.

All active addresses are used by default. Select or deselect the target IP address by using the drop-down menu.

Note The active network services can be found in OS X by going to System Preferences > Network.

Port

Note Switch the Web service off to make changes to the following option.

Merlin Server uses the Port 7180 for the Web service. If the port is already used in your company, you can set another port for the Web service.

Hostname

Note Switch the Web service off to make changes to the following option.

The hostname of the Web service is adopted automatically from the router or no explicit hostname is used. If you want to use your own hostname, click the Edit button.

Web: Hostname

Then select the option »Use hostname« and enter an IP address or a dedicated hostname in the field.

Data Source

Note Switch the Web service off to make changes to the following option.

This option tells you whether the Web service on the Merlin Server used by you or another Merlin Server installation is acting as the »data source«.

Click the Edit button to use a different data source.

The local sync service is activated by default.

Web: Data source
Note Should you need to select another sync service from another Merlin Server, click Sync service from a different Merlin Server installation and enter the URL of that Merlin Server.

Certificates

This option lets you use your own certificates for Merlin Server.

Server:Certificates
Note Stop Merlin Server to change or create certificates.

Click the plus icon. You will find two options in the drop-down menu.

Server:Creating Certificates
  • Create a Certificate Identity…

  • Import a Certificate Identity…

Creating a Certificate

This option lets you create your own, self signed certificate. In the dialog, enter the hostname for the certificate and a validity in days.

Server:Creating Certificates

Importing a Certificate

This option lets you import certificates with a private key or public certificates in the form of files.

Server:Creating Certificates

Deleting Certificates

Use the mouse to select one or more certificates from the list and press the delete key on the keyboard.

Server:Deleting Certificates

Licenses

Merlin Server is activated with a license file. If you do not have a license file, you can test Merlin Server absolutely free of charge for 30 days.

30-Day Trial

Once you have downloaded and installed Merlin Server you will see this dialog. Click »Start 30-day trial«. This now starts your 30-day, zero-restriction demo.

Server:License Demo 30 Days

Click the blue banner to access additional demo-period options.

Server:License Demo 30 Days Banner

Managing Licenses

On the sidebar, click »Licenses«. Here you can see your license(s) as well as search for your lost licenses or buy new ones.

Server:Managing Licenses

Use the plus or minus icons to import new license files or remove licenses from the list.

Once the demo period has ended, Merlin Server will no longer be licensed. This is indicated by the blue banner »Not licensed«.

Server:No Licenses

Click the banner to buy new licenses or drag & drop your existing license(s) into the window or click the plus icon.

If Merlin Server is unlicensed, the services will be inactive. You can tell this from the red icons.

Server:Server down

Tenants

The tenants option is for users who want to offer the services of a single Merlin Server to multiple customers (tenants).

If you are interested, please contact our Sales team for a quote. To do this, simply click the »Request Quote« button.

Server:Tenants
Note An active sync service is required.