About this document

Merlin, Merlin 2, and Merlin Project are successive versions of the popular project management software for Mac OS X which were released in 2004, 2006, and 2015 respectively. This document will be of interest for Merlin Project 3.x users or those of Merlin 2, as it describes the changes of the current Merlin Project application compared to the previous versions.

In Merlin Project 3.x

This topic will be of interest for Merlin 2 users.

  • Merlin is now called Merlin Project. The suffix Project in the app name puts the focus to the software’s purpose.

  • The app icon was redesigned.

  • The minimum system requirements were raised to OS X 10.9.5 Mavericks.

  • The design of Merlin Project has been greatly enhanced in many areas. Merlin 2 users will quickly get to grips with the new software based on their existing knowledge.

  • The full functionality of Merlin Project can be used for a full 30 days without requiring a license. If no license is purchased following that period, Merlin Project runs as a viewer. It cannot create new files but opens existing Merlin Project files.

  • Merlin Project allows you to script project data and the user interface and thus automate frequently used workflows. Supported are both dialects, AppleScript and Javascript. Merlin 2 would allow to script only the project data.

  • Shared folders like DropBox, iCloud Drive or Google Drive are now supported. However, you cannot yet manually choose between document variants which are conflicting each other.

The user interface

  • The look and feel of the software has been heavily modernized. It now features a texture which darkens the background to put more focus on the content in the foreground.

  • Project Settings no longer appear in a dialog. They are moved to the Inspector. Project settings are the first things to be shown when creating a new project. As soon as another object is selected, its inspector appears in the same place. The project settings can be accessed at any time by clicking the Settings icon on the main toolbar.

    Project Settings
  • Inspector: The content of the inspectors was restructured based on the latest didactic findings.

    • Additional inspectors exist now for: Time Scales, Filters, View Options, Styles, Contents, Columns, Report modules and Project Settings.

    • Inherited settings: The Inspector now supports the L-shaped arrow symbol L-shaped arrow. This indicates that standard values are inherited from an overlying object.

    • The ESC key can now also be used to cancel entries in the Inspector.

    • Inspector fields auto expand to fit longer text entries.

  • Animated application reactions: Many actions in Merlin Project are now animated. This gives the user a better understanding of what is happening in Merlin Project.

  • The view switcher has been moved from the toolbar on the top/left area of each view and to the View menu. Click this to see a list of all available views.

    Changing Views
  • The views are freely configurable in terms of purpose, column configuration, and style. Each view can now contain any number of view configurations.

    View Configurations
  • The main menu has been regrouped in a completely different way. The assigned keyboard shortcuts have also been revised.

  • The New, Indentation, Chain Activities, and the gear button (Action functions) have moved from the View toolbar to the main toolbar.

  • The Resources Well has been shifted from the bottom right corner of the window to a popover on the main toolbar. The Resources popover can also be displayed in a separate window and positioned manually on the screen.

    Resources
  • The toolbar has been greatly expanded. It now features several icons which, while hidden by default, can be configured really easily:

    Toolbar
    • Create New objects (shown by default)

    • Indentation (shown by default)

    • Link activities (shown by default)

    • Attach new items (hidden by default)

    • Insert new Space (hidden by default)

    • Action button as an alternative to the context menu (shown by default)

    • Show Warnings (hidden by default)

    • Highlight Critical Path (hidden by default)

    • Show Library (shown by default)

    • Show Resources in a popover (shown by default)

    • Show Project Settings (shown by default)

    • Show/Hide Details view (shown by default)

    • Show/Hide Inspector (shown by default)

  • The scrollbars have been removed to ensure consistency with the rest of the system.

  • Elements:

    • The Merlin 2' “Elements have generally been renamed to Attachments. The individual attachment types are still available (Check List, File, Event, Information, Problem, Risk).

    • The “Elements" view is now called Details view and has several additional functions (details below).

  • A project window can now be displayed in Full Screen mode. This hides the toolbar and enlarges the rest of the window.

  • All views can be zoomed in and out using the zoom function (Apple key and +/-).

  • Retina display support: The entire application has been optimized to be resolution-independent for viewing on Retina displays.

  • Almost every area of a project view can now be designed following style definitions. These are generally rule-based as in Merlin 2, but they have been greatly expanded. Users can define their own rules which then control the design.

  • Warnings: A Warnings window lists now Scheduling warnings, together with the new Import, Export and Publishing warnings. The distinction in Merlin 2 between warnings and conflicts has been renamed to weak and strong scheduling warnings.

    Warnings Dialogue
  • Project Templates now appear in a submenu. This is populated from the usual sources:

    • built-in templates,

    • ~/Library/Application Support/Merlin Project/Templates,

    • /Library/Application Support/Merlin Project/Templates

    • /Network/Library/Application Support/Merlin Project/Templates

  • The separator line between the Outline and Gantt chart or Resource Groups and Resources outline now appears thick if one of the areas is hidden.

More views

New features for all views
  • New Views: A Report view and an Attachments view has been added to the list of familiar views.

  • View Configurations: Each view can contain any number of view configurations. These can be accessed in a list at the end of each view. Each view configuration contains its own column set which is saved together with a style set.

  • A standard set of view configurations is provided for each view. The user can edit or add to these via the “Edit” menu. Shared view configurations are also supported. Depending on how these functions are used, “Custom” and “Shared” entries are added to the “Built-In” entries.

  • All view types can now be freely selected and shown in the main view or the Details view.

  • cmd-F in any view: It is now possible to search text using cmd-F.

  • tab Control: Tabbing while editing a cell in a table view, iterates all cells of all visible rows.

  • If the user hovers the mouse over a column header, a little triangle appears in a circle on the right-hand edge of the column. By clicking it, a context menu will be offered containing various functions for this column.

  • Outline column: You can now define as the outline column any desired column. In previous Merlin versions, the outline column was fixed and set to the 'Title' column.

  • Clicking a column title displays the Inspector for the column.

  • Double-clicking a column title opens a list of all columns enabling the user to change the type or create new custom columns.

  • Double-clicking column separators in the header adjusts the column width so each item of column content is displayed on a single separate line.

  • Remove columns by key: To remove columns from the Outline, you may now select their table-header and press the delete or backspace keys; Built-in columns will be hidden. When removing user-defined fields, the app will ask whether just to hide or to also delete the user-defined field and its values.

  • Sorting options in context menu: Manual sorting of the Outline view can now also be activated via the context menu in the table header. If this is not possible for some reason, the program will inquire.

  • Wrap/Clip/Truncate options: Content now responds even more dynamically to the column width. Various types of formatting, which adjust automatically, are now available for many columns.

  • Merlin 2’s Gantt View Options are now shown in the Time Scale Inspector.

  • More menu commands for reordering columns. Move up and move down commands are now available for tables that can be sorted manually in addition to the known indenting and outdenting.

  • If a column set is changed (via the table-header context menu) and the current column set was changed previously, the user can now save the former column set (optionally under a new name).

  • Simplified columns set: When adding a new column to the outline, the column list shows a simplified columns set. The list responds to a typed column name and will offer matching columns. You may nevertheless scroll to the end of the columns list and switch between “More/Less” and in doing so influence the number of results shown.

  • Column formats can now be configured according to the data type. The table-header context menu offers different format options for numbers, dates, durations, and work.

  • More options for User-defined fields

    • New additional types: Flag, Checkbox, Media.

    • Pre-defined values: If defined they will be offered in a list for the Merlin user to select when recording values for this user-defined field in the outline.

    • Summary options: Total, average, minimum, maximum, state, or hidden. A summary row is a row having child activities.

    • Number formats: Various number formats are supported (number with unit, etc.)

    • Quicklook is supported for visible media user-defined fields (Press spacebar to display their Quicklook presentation).

  • You can now assign tags to activities, assignments, resources, and attachments. Tags can be shown in the views just like regular columns or viewed in the Inspector.

  • Column or Line Separators: It is now possible to enable and style column or line separators.

  • Styling table-header rows: You may style the table-header rows and/or colors of separator lines between columns, rows, and time cells.

  • Auto row height: The table row height now adjusts dynamically through the use of line breaks and can be further controlled using style rules.

    Auto row height
  • URLs and text formatting in cells: Text fields now support formatting and URLs. Formatting follows style-rule formats.

  • The field editor for date cells in the Outline or Inspector has been redesigned:

    • The default date is now shown in gray.

    • Date segments can now be changed by dragging the mouse to the left or right.

    • The popup calendar has been redesigned.

      Date Calendar
  • You can open/hide view areas by context menu entries: 'Show Gantt Chart', 'Hide Gantt Chart', 'Show Resource Groups', and 'Hide Resource Groups'.

  • 'Show Overview' is now available over the context menu instead of a button in the bottom of the Merlin view.

  • The Outline and Gantt chart display have been merged more uniformly:

    • It is now also possible to drag dependencies between rows from/to Outline and Gantt.

    • Dragging rows for reordering became easier and works in the Gantt or Outline.

    • The complete row will be highlighted by the selection color and not just the Outline.

  • Gantt views using boxes and histogram rows can now be exported as HTML.

  • The inspector for the root activity does now allow the full set of start date constraints.

The Work Breakdown view

  • The Activities view is now called Work Breakdown.

  • # column for assignments: Assignment rows are not numbered anymore in the Work Breakdown view.

Columns and Outline
  • Auto expand: The “Title” column now supports longer texts and adjusts its height accordingly. Certain text formats (bold, cursive, underline, as well as color & outline) including hyperlinks can be entered. OS X’s key typographical functions as well as grammar checking is supported.

  • Activity constraints (mode + new concept: ASAP, ALAP or long) can be set much more easily.

  • Inheriting alignment: Activity alignment (ASAP, ALAP or long) can now be inherited.

  • “Optimize Duration” is now called “Minimize Duration”.

  • Traits column: The Info column has been renamed to Traits. The folder icon on a project row is now moved into this column along with the other trait icons.

  • Flag status shapes: The flag status has been replaced with traffic light-colored shapes which are abstract, but easily identifiable even to those with vision problems:

    • Red = Triangle

    • Yellow = Square

    • Green = Circle

      Flag shapes
  • Auto status: The activity status can now no longer be assigned manually, but always calculated automatically.

  •  The activity status calculation has been optimized:

    • Blue: Activity pending.

    • Red: Activity significantly behind schedule (>10%)

    • Yellow: Activity slightly behind schedule (<10%)

    • Green: Activity on schedule.

  • The status-assignment rules are now explained semantically in the Outline and Inspector.

  • It is now possible to manage table columns using the column header:

    • Clicking the column title shows the information in the Inspector.

    • Clicking the small circular icon in the table header opens a context menu offering a wide range of settings.

  • Child activities inherit now the precedence setting of activity calendars.

  • Planned overtime work can now be assigned. In Merlin 2, only the actual overtime work option existed. The overtime work concept was harmonized with the one in MS Project in respect of optimizing importing and exporting.

  • WBS codes are now editable and fully compatible with those in MS Project. There is in addition a new column called 'Outline Codes'. 'Outline Codes' are the WBS codes of Merlin 2; not editable and incompatible with the WBS codes used by MS Project.

  • The "# Predecessor" and "Predecessor" columns were consolidated into one column (with formatting options).

  • The content of the Activity: Finance Inspector has been divided into three areas (Budget, Cost, Balance).

  • The Review Date field in Budget has been removed. If such a field is required, the same function can be reproduced using a user-defined field. In a later version of Merlin Project, a completely revised concept will be presented.

  • User-defined fields with same title but different types can now be shown in a single column.

  • In the activities inspector, the options for the calendar precedence now refer to assignments instead of resources.

Gantt chart
  • Restricting the visible date range of the Gantt, enabling the time line, the current time unit, and the grid lines, have moved to the timescale Inspector. To activate the timescale Inspector you click a timescale header row in the Gantt.

  • The time units of individual time-scale rows can now be fixed.

  • The Gantt chart now behaves like a custom column and can now, like all columns, be grabbed at the edge and its width modified. If the Gantt chart is fully shown or hidden, a wide grab box will appear on the left- or right-hand edge of the view.

  • The display of information in the Gantt chart has generally been revised. The path of connecting lines has been significantly optimized.

  • There is a new type of highlighting for all objects in the Gantt chart: “halo”.

  • To activate or disable the display of the critical path you can now call a 'Show Critical Path' menu item or use a toolbar item.

  • The critical-path calculation has been improved.

  • The time-scale labels stay at the edge of the visible area for as long as possible.

  • Scaling of the time scale by dragging the mouse has been improved.

  • New 'Complete work as of…' item in the time-scale context menu: Marks automatically work as being complete up to a clicked point in time.

  • If the user chooses to limit the displayed Gantt-chart date range, a blue indicator row appears now in the time scale starting on start and ending on end of the selected date range. This indicator is not a printable element.

  • Time-scale units can now be defined by dragging them with the mouse. If you drag to the right, the time scale shows more (finer) details. If you drag to the left, fewer (more general) details are shown. If the Shift key is held depressed while dragging the mouse, the time scale does not switch automatically to other units (which may be more meaningful for the current width).

  • Clicking a scale shows various settings in the Time-scale Inspector:

    • The allocation of time units and the format for the selected time scale is now only configured in the Inspector.

    • The Gantt view options of Merlin 2 or now in the Time-scale Inspector.

    • The “Limit the visible date range to display” function of Merlin 2 now appears in the Time-scale Inspector.

    • The calendar used in the Gantt chart view can now also be configured in the Inspector.

    • The Gantt chart can now also hide non-working times in different levels, whereby the underlying calendar can be specified.

  • Default colors now indicate the new status calculation. See more here.

  • The zoom function initially only zooms into/out of the width of the Gantt chart. The entire content of the window is zoomed into/out of if the Alt key is also held depressed.

  • Double-clicking the left-hand edge of the Gantt chart rests this edge automatically against the edge of the nearest column.

  • Colors of non-working times, the current unit, and the time line can be configured using styles.

The Net Plan view

  • The net plan can now be displayed in various layouts:

    • Top-Down

    • Mind Map (left-right layout)

    • Organizational Chart (top-down layout)

    • PERT

  • Cells in the Net Plan boxes can now be configured more extensively.

  • You may now edit shown values directly in the Net Plan boxes.

The Resources

  • Default Resource: All new projects automatically contain a Default Resource. Default Resource is listed in the Resources and Assignments views.

  • Default financial data, available units for all unassigned activities, used to be located in the Project Settings, they are now accessed in the Inspector of the Default Resource.

  • Guest / Registered User: In addition to registered user-resources, you may not allow guest (anonymous) access to your projects. To restrict the permissions of the Guest user, you modify the permissions of the Default Resource. To disable Guest access, you simply disable the 'Is User' option of the Default Resource.

  • Base Costs: Resources now have base costs, replacing costs per project/activity.

  • Actual values for resources can now be viewed in the Inspector.

The Assignments

  • Assignment rows in the Work Breakdown view, are not numbered anymore.

  • The Utilization view has been renamed to Assignments view.

  • Utilization can still be analyzed in Assignments view, or if desired in the Work Breakdown view as well. A specific configuration for the Assignments view is already included per default.

  • You may now call the #, Code or WBS Code columns of the assignment’s activity in the Assignments view

  • The specific for the Utilization view time-box oriented evaluation can now be performed in all Gantt views and activated if required dynamically for each row.

  • Each Gantt row can display up to three time-phase rows with boxes or histograms.

  • A column with descriptions for time-phase or histogram rows will be now shown/hidden dynamically if more than one value type is displayed.

  • There is an option for Time Phase Descriptions in the View Options Inspector.

  • Time cells can now display considerably more fields (precise list).

The Report view

  • Reports no longer appear in an additional report window. Instead, a new “Report” view has been introduced.

  • All supplied reports are listed in the view’s configuration list.

  • Users can now generate custom reports using report modules.

  • Supplied report modules:

    • Bar Chart: To compare numerical values or durations graphically.

    • Budget Cost Chart: To compare assorted budgets and cost types graphically. A grouped or layered bar chart is displayed.

    • Project View: Any view of a project. As part of this, data tables are included in the report.

    • Text: Custom text.

    • Time Phase Chart: To display numerical values or durations on a time axis.

    • Time Phase List To display the distribution of numerical values or durations on a time list.

  • Report modules can be selected using the mouse. The Inspector offers various configuration options.

  • A report is freely customizable in its style. Style settings are available over the Styles context menu.

The Attachments view

  • Attachments may now also be selected in the main view. In this case, all attachments, including those created for resources, are displayed.

  • The Review Date fields in the Check Lists, Files, Events, and Information attachments have been removed. If such a field is required, the same function can be reproduced using a user-defined field. In a later version of Merlin Project, a completely revised concept will be presented.

The Details view

  • All view types are now also available in the Details view, not just the Attachments view.

  • The Details view focuses on the selection made in the main view. If, for instance, a group is selected in the main view, the Details view only shows the content of the group. Here, any combination of views can be selected:

    • Work Breakdown in the main view

    • Net Plan in the Details view

    • Report in the Details view

    • Assignments in the Details view

    • etc.

  • It is possible to stop the Details view from focusing on the selection.

  • File attachments are now always copied to the project.

  • Export Formats for Checklists: Checklists can now be exported in all available formats.

Key functions

Autosave and undo

  • Merlin Project performs autosave.

  • Merlin Project now supports persistent undo. This means additional steps can be undone even after the file has been closed and reopened.

Language settings

  • Application Language: It is now possible to specify the application language in the Merlin Project’s Preferences and select another language than the System language.

  • Language of the built-in templates: In Merlin Project’s Preferences, it is now possible to specify the language the built-in templates are listed in. If the templates in the Library directories are structured including further folders, these are displayed in the submenus.

Project Settings

  • Project settings are now displayed in the Inspector.

  • You can now define default work and/or duration values for new activities.

  • There are granularity parameter for dynamic planning.

  • There is a new automatic format for Resource initials.

  • The selection popup and Action menu for editing project calendars have now been consolidated into a table.

Find & Replace and Jump to

  • Find & Replace: Besides the filter functions (described below.), it is now possible to search for text in each view (numbers, durations, and dates are treated as text). This search is integrated similar to the function in Safari and other programs. Like in other Apple programs, the search function offers a host of options which are not immediately discernible:

    • In the context menu behind the magnifying glass it is possible to define whether the search should include uppercase and lowercase letters, whether the entire document should be searched, as well as to specify the search components - even as a regular expression.

    • If the “Replace” option is checked, by clicking and holding the “All” button, the scope of replacements can be configured.

  • Jump to: It is now possible to jump to the current selection or an activity using its #, outline or WBS.

Actual Values

  • The concept for managing actual values has been greatly simplified.

  • The user no longer has to distinguish between absolute and percentage-based progress.

  • Remaining Work will be now automatically calculated and becomes thus available in according column or inspector field when a user enters the actual values. This provides an even more transparent target/actual comparison.

  • Actual Overtime Work will be now automatically calculated from the actual work value a user enters.

Filter

  • The Filter are replacing the advanced search from Merlin 2. Instead of working in a small context menu, now the entire inspector can be used for the filter.

  • After clicking the Filter icon, a list of named filters appears in the Inspector.

  • The filter name is displayed to the right of the filter icon on the View toolbar.

  • Enabling a filter: To activate a filter, you click the small filter icon next to its name.

  • Filter rules now allow analyses to be performed along the relationship path as well as the analysis of time windows and data analyses relative to the status date.

  • Overflowing Filter icon: The activated filter icon changes to the “overflowing” filter icon if data is added while a filter is enabled and the new data does not fit the filter specifications.

  • Clicking the Filter icon again brings up the list of named filters again. Here, the “overflowing” filter can be deactivated.

  • A filter rule can be viewed and edited by clicking the magnifying glass icon at the end of the filter row. For further information, see “Rules Editor” below.

Print

  • The Print option has been completely redesigned.

  • Instead of a custom preview, the standard print dialog is used.

  • The settings for the content, page distribution, header and footer rows, as well as borders to be printed have moved to print dialog menus.

  • Instead of the project image, a watermark, which is activated in the print dialog, can be inserted and scaled. The watermark follows pagination.

Styles

  • The styles and content rules have been separated from each other.

  • View styles are now selected via the context menu.

  • The Styles editor now appears in the Inspector.

  • Custom style conditions can be created.

  • There are countless new style attributes:

    • Fonts,

    • Colors,

    • Margins,

    • Line thicknesses,

    • Minimum/maximum heights, and much more besides…​

Import

  • Importing MS Project files no longer requires a Java backend.

  • Importing Mindmap files has been divided into individual FreeMind, MindJet, and NovaMind modules.

  • When importing Merlin 2 file where no "actual end date" is set, Merlin Project sets the actual completion to 99%. This is a new behaviour because Merlin Project needs an "actual end date" to finish an activity.

  • Implemented import notification for MS Project files containing null tasks (empty rows).

Export

  • The Export dialog has been redesigned. A list of all available export formats now appears on the left.

  • It is now immediately identifiable which data will be exported (current view, entire project) in the export-format settings.

  • The export can be attached directly to an email via the “Send as Email” menu which first opens the export dialog and then sends the resulting file to the email client configured in the system.

  • To export as an ics file, filter rules can now be applied in advance to the individual Activities, Events, and Assignments export options.

  • When exporting as an image, it is now also possible to include a watermark. The settings are the same as for the Print option (see more.)

Publish & Subscribe

  • Under the generic term “Publish & Subscribe”, actions can now be defined which, once saved, can be used to manually update other publications with project content and update project content from external sources. This option will be enhanced at a future date to include automatic and scheduled updates.

  • With the Merlin Server 4, it will also be possible to automate the publishing process according to a schedule.

  • The "Calendar" module can populate the OS X Calendar app.

  • The "Reminders" module can populate the OS X Reminders app.

  • The "Export" module sends content (exported views) as a local file either to an FTP server, a WebDAV server or via SMTP.

  • All events published to the Calendar app now contain special URLs. You can only publish to calendars which exclusively contain events from Merlin Project. This prevents Merlin Project from accidentally deleting manually created events. If you have created calendars for Merlin Project 3.0b5 or earlier, you should delete and recreate them.

Merlin Server

  • Merlin Project and Merlin Server (for Merlin 2) cannot run together. If you need to use Merlin Server for Merlin Project, update to Merlin Server 4.

Note Merlin Server 4 requires Merlin Project 4.

Rules editor

  • Settings follow rules in many areas of Merlin Project. Like many other rules editors (e.g. in Apple Mail), this is also implemented in Merlin Project but with a few key additions:

  • In the first row, besides “AND’ and “OR”, “NOT”, a negation, can also be used.

  • The second row starts with the preselection of the data type. e.g. “any type, activities, assignment” in the filter-rules settings.

  • Following that, all included columns are listed. Simplification of the data lists is applied again here too. At the end of the list, it is possible to switch between “More/Less”.

  • Following that all potential conditions are listed (is equal to, is greater than, etc.). For certain columns, it is possible to set a relationship via “meets condition”.

  • In some instances, such as in the case of the filter editor, presentation can ultimately be affected. The result can:

    • “Show non-matching hierarchy”

    • “Show only matching hierarchy”

    • “Show as a flat list”.

Resource Leveling

  • Resource-leveling settings are now displayed in the Project Settings Inspector. They can still be opened under the “Edit > Resource Leveling > Leveling Settings” menu option.

  • When leveling by priority, 1000 priority levels can be used now instead of the 5 in Merlin 2.

  • Merlin 2' “Utilization” activity parameter is now called “Resource Units”.

  • More units had been added to the over-utilization intervals.

  • The “Relative to Standard Utilization” option has been removed. In Merlin Project, the “Resource Units” are always used to calculate utilization.

  • The leveling delay following resource leveling can be edited in the Activities Inspector.

Earned Value Analysis

  • Earned value analysis is now supported. According to Wikipedia, it is a project management technique for measuring project performance and progress in an objective manner. By using key figures to describe the current schedule and cost performance of a project, it is possible to generate a trend analysis by tracing those key figures. For this purpose, Merlin Project has defined views and reports.

In Merlin Project 4.0

This topic will be of interest for Merlin Project 3.x and Merlin 2 users.

Synchronization

You and several users can now work on the same project using multiple devices.

File based synchronization

Individual users and small working groups can simply store Merlin Project files on a shared network drive (AFP or SMB) or on a cloud server (iCloud Drive, Dropbox, Google Drive, etc.) and Merlin Project 4 will synchronize all changes automatically.

Clouds

Manual change integration

You can also integrate changes into your project which you receive such as by email or on a USB stick. Just use the new command “File > Integrate Changes…​” and select the file version whose changes you want to incorporate.

Working groups with Merlin Server 4

Merlin Server 4 also allows mid-size and large working groups to work in a scalable way. By installing this software, you can turn an OS X computer into a synchronization center in just a few clicks. Users can now publish documents to this server directly from Merlin Project and subscribe to them from there. All changes are synchronized automatically, even over low-bandwidth Internet connections. You can also work on projects whenever you want even without an Internet connection. As soon as you’re back online, all interim changes are synchronized automatically.

User Resource and Permissions

Merlin Server 4 is easy and convenient to use as you never need to manage users separately: Mark a project resource in Merlin Project as a user and this user can then use Merlin Server’s services right away.

Publishing using Merlin Server 4

Merlin Project 3 already allowed you to publish project content automatically via FTP, SMTP, and WebDAV. Merlin Server 4 now lets you do this at regular and specific intervals even when your computer is switched off. To use this function, all you need to do is set up the required FTP, SMTP, or WebDAV accounts in Merlin Server 4 under “Publish > Accounts”. You can then select them in projects which you have subscribed to using Merlin Server via the “Publish” dialog. The days and times at which Merlin Server will automatically publish the content can be configured under the “Publish” tab.

Publishing using Merlin Server

Merlin Server 4 Web server

Merlin Server 4 includes an integrated Web server which allows users to view project content in their Web browser even if they don’t have a Mac.

Publishing & subscribing to documents in Merlin Project 4

Merlin Project 4 features a new “Sync” icon in the sync toolbar for synchronizing projects via the new Merlin Server service. This lets you create server accounts and view a document’s synchronization status.

Publishing & subscribing to documents using Merlin Server

If the icon is blue, you are connected to a Merlin Server. If it is rotating, data is currently being synchronized.

Merlin Server Sync

To publish documents on a server or to subscribe to them again, a new window is available which you can access by going to File > Merlin Server > Documents.

Work Areas

As Merlin Server automatically synchronizes all your changes, other users can also see these immediately. However, there may be situations where you don’t want this to happen, such as when performing a major, lengthy change to the project or experimenting with the project structure. For this purpose, we’ve introduced the new “Work Areas” function to the toolbar.

Private and Public Work Area

There are two work areas which each user can switch between freely.

Private and Public Work Area

In the Public Work Area, changes are synchronized automatically between all users and devices.

In the Private Work Area, a user can make major changes without interruption. The user’s changes remain in this area until they are manually published or discarded. The user’s private changes are, however, available to the particular user on every device (Macs, iPhones, iPads) and are synchronized automatically.

Updated export function

Merlin Project 4 now lets you export more than just one view at a time in virtually all export formats. In the Export dialog, you can choose between the current view or a self-selected list of views.

Updated Export Function

If you select PDF as the image format, the views are exported as pages of the same PDF file. If you choose HTML as the export format, an index.html file is generated which includes all selected views. Just like in Merlin Project, you can then switch between the included views in the browser. You can now expand and collapse activity groups in the browser.

Additional changes

  • In the Earned Value Analysis, the budgeted costs of work performed (BCWP) are now added to the groups.

  • When selecting the menu option "File > Duplicate…​" a dialog appears first which allows you to view the document history and create a new document identity.

  • The status of groups in the Inspector is now saved in the document.

  • A new file format has been introduced with the changes in Merlin Project 4: Merlin Project 3 files are integrated automatically into the new file format; Merlin 2 files are imported into a new document.

  • Merlin Project 4 now runs in a sandbox. For further information, see Wikipedia.

Merlin Project Go

We’ve launched a new app “Merlin Project Go” for mobile users. It lets you access all your project’s information and edit it both offline and online via iPhones and iPads. Changes can then be synchronized with other users via the new Merlin Server 4 service. The display of project content has been optimized for mobile use on small screens. For further information, see Merlin Project Go.