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Note for Merlin Project Express users
The following functions are only available in Merlin Project.

This guide contains information about the Kanban system in Merlin Project.
Kanban is a Japanese term and has a wide range of meanings such as card, board or
document.

What is Kanban?
Alongside Scrum, Kanban is one of the most widely used methods in project management.
It was originally developed for production management, meanwhile the agile method is
now also used widely in project management.
The use of Kanban offers improved utilization, higher transparency, and faster iterations
during the project.

Kanban principle
The Kanban system is based on cards that can be moved from left to right in column rows
along a board.
Every to do is noted on a card. Depending on the processing status, a card moves along
the board from left to right until it is completed.

In moving along the columns, the cards are given a defined status. As the project
progresses, an increasing number of cards move from left to right.

Columns in Kanban
In the simplest Kanban system, the Kanban board is split into three columns. The cards
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always move from left to right.

To Do: In the left-hand column, to dos are entered that have not been worked on yet.
These to dos are planned and are to be worked on soon.
In Progress/Doing: As soon as work starts on a to do, its card is moved to the center
column. The card remains in this column while being worked on.
Done: Once the to do is done, the card moves to the right-hand column. This means that
the to do has been completed successfully.
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Columns in Kanban

Kanban in Merlin Project
Merlin Project lets you plan using traditional and agile project management methods, and
to switch between them or even use both simultaneously whenever you want.
The progress and thus the status between the traditional and agile planning method views
is updated automatically. This unique function lets you work flexibly and plan using
different methods.

The boundaries between agile and traditional project management have finally vanished
with the introduction of Merlin Project.



You can switch whenever you want between the traditional Work
Breakdown > Entry and Net Plan > Kanban view. Activate the
secondary project view for a simultaneous overview of both methods.

Choose between two Kanban display modes in Merlin Project: Traditional and Compact.
For the compact view, from the Net Plan drop-down menu select the Kanban Compact
view.
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Using the Kanban view
Kanban offers a very flexible approach to working with projects. Read on to learn how you
can get off to a quick start with Kanban in Merlin Project.
Open a new or existing project. To do so, click File > Open or use the keyboard shortcut
cmd + O.
To create a new project, click File > New or use the keyboard shortcut alt + cmd + N.
Change from the Work Breakdown > Entry view to the Net Plan > Kanban view.
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You can switch quickly between views using the View menu. Just click
View > Net Plan > Kanban.

Using the Kanban view

Creating the Kanban view
When you first access the Kanban view a notification will appear with the button Group by
status field.



Kanban needs to be grouped by a status field and the status values it
contains for the Kanban columns.

Click the button to open the Grouping by Status Field wizard.

The wizard includes pre-defined status field templates.
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See the »Groupings« guide for further information on "groupings" in
Merlin Project.

The options »by new field:« and »Simple Kanban« are preset automatically. Click OK to
work with this Kanban status.



"Field" refers to custom fields. These fields can be created and
managed in any Activity Inspector under the »Tags and Fields« tab.

The status values in the supplied »Simple Kanban« field can be seen as columns in the
Kanban board.



New fields can be created or existing ones edited quickly. See the Tags
and Fields guide for further information.

You can arrange the Kanban cards based on these status values and edit them with a
defined Kanban status in the traditional view.
The status values can be changed in the wizard. Click on an entry to change it.



Read on to learn more about the individual status value options.

Click the plus to create new status values or click minus to remove them.



6

The »Simple Kanban« field is perfect for a variety of projects. It makes
it quick and easy to get started with the Kanban methodology.

Creating the Kanban view

Applying the Kanban methodology
The following tells you more about using Kanban in Merlin Project.
The status values from the »Simple Kanban« field appear in separate columns in the
Kanban board.
The columns are arranged from left to right with the following status values:
• Backlog
• In process
• Verifying
• Done

If the project has activities, these appear automatically in the columns as Kanban cards.
The card’s status in the project dictates in which column they are arranged.
You can create new Kanban cards by clicking the plus icon or using the keyboard
shortcut cmd + N.

The card that is created appears automatically as an activity in the traditional view. Click
the arrow on the right next to the plus icon to create further card types as well as
attachments.
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The same functions as appear under the arrow can also be found in the
Insert menu.

Select one or more cards and then click Attachment.
This option lets you add any files or information to the selected card(s). Attachments are
represented by a paperclip in the lower left corner of the card.
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Applying the Kanban methodology

Wizard: grouping Kanban by status field
Grouping by status field is required for the Kanban view.
The wizard includes the following status field selection options:
• by new field from template:
◦ Simple Kanban
◦ Software Development
◦ Issue Fixing
◦ Editor
◦ Exhibitor
◦ Sales
◦ Attention level
◦ Field with custom status values
• by existing field:
◦ Status (calculated)
Once you have selected the status field, a preview will appear of the status values
contained in the status field.

The by new field from template option lets you start directly with a new pre-defined
template. This is the easiest way to create a Kanban.
The drop-down menu options can already be used for a variety of projects. The by new
field from template option lets you select custom fields, that are already included in the
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project, to group the columns.



In newly created projects, the existing Status (calculated) field appears
in the drop-down menu.

The Status (calculated) field differs from most fields as it accesses the values calculated
in the project. This means you can no longer move the Kanban cards in the Kanban view
manually; they are moved automatically by the values calculated in terms of the project’s
progress.

Should a Kanban board be grouped by Status (calculated), the Unscheduled column is
shown as a single column until the project is progressing within actual values.
The status can be also shown in a column with the same name in the Work Breakdown >
Entry view.

Re-accessing the grouping wizard
Click the Grouping icon to display the list of built-in groupings.
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Re-accessing the grouping wizard

Click the gear icon in the Group Inspector and a drop-down menu will appear as shown.
Click the option Group by Status Field.

The Grouping by Status Field wizard will appear. Select your desired grouping for the
Kanban view.

Creating custom groupings
Click the Grouping icon to display the list of built-in groupings.
Click the plus icon on the bottom left in the Group Inspector. A new grouping in the
"Custom" category will be created.
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Name the grouping and then click the magnifying glass.

The dialog for modifying the grouping will be displayed. You can set the grouping options
here. The view will be grouped based on these options. To do so, use the drop-down
menu.
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Creating custom groupings

Click the plus icon to add additional grouping conditions. Click the minus icon to remove
them again.

Click the rectangle on the left next to a grouping to activate it and apply it directly in the
Kanban view.
You can modify existing groupings if required. To do so, select an



existing grouping and click the magnifying glass to the right of it. Once
you have modified it, the new configuration will be adopted in the
selected grouping.
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The active grouping will be displayed next to the grouping icon. Click it to access the list
where you can change or modify the grouping whenever you want.

Adjusting status fields
Click a column title in the Kanban view to display the "Group" Inspector. The clicked value
of the status field will be displayed there and can be adjusted.



Columns with calculated values are an exception as these cannot be
changed or adjusted in the Inspector.

You can choose from the following options in the "Group" Inspector:
• Value (column title name)
• From Completion (drop-down menu with completion values from 0% to 100%)
◦ Edit All Values… (displays the Custom Fields Inspector)
◦ Select Status Field (displays the Grouping by Status Field wizard)
• Number of Cards
◦ Minimum Count
◦ Maximum Count



The Grouping by Status Field wizard includes the same settings for
the values.

Click the Edit All Values option in the Group Inspector to open the Inspector for the
current grouping values. See the Field Values Inspector section for further information.
The Minimum Number option lets you set the minimum number of cards displayed in the
column.
If you set a minimum number of cards, a counter with the current number of cards and the
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Adjusting status fields

minimum number set is displayed in the title column.



If the minimum value is higher than the current number of cards, the title
column is highlighted in orange.

The Maximum Number option lets you set the maximum number of cards displayed in
the column.
If you set a maximum number of cards, a counter with the current number of cards and the
maximum number set is displayed in the title column.

Kanban fields
You can edit and adjust the field values in the Custom Fields Inspector.
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These field values set the progress for the cards and in doing so for the activities in the
Kanban view and other views in Merlin Project.

Field Values Inspector
The current grouping and associated values can be found in the Custom Fields Inspector.
Click the icon to the right of the value and all available values in the active grouping will
appear in the drop-down menu. These values are used for the columns in the Kanban
view. The selection is applied immediately for the selected card(s).
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Field Values Inspector

Pre-defined values
You will find a list of pre-defined values for the active grouping further down in the
Inspector. Click the plus icon or minus icon to add/remove values to the grouping.

The values can have different properties. These are:
• Value
• Completion
• Min
• Max
• Level
Value is also the title of the column in the Kanban view
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Completion controls the progress of the activities both in the Kanban view and in all other
views.
The following options are available:
• Empty (no completion)
• Not started
• 0% to 100% (in increments of ten)

When entering a % value for an activity that corresponds to the % value in the Completion
column, the card associated with the activity is moved automatically in the Kanban column.
Conversely, you can also move a card manually. If you move a card in this Kanban column,
the activity is assigned the % completion value automatically.
Min is the minimum number of cards in the Kanban column. This value corresponds to the
Group Inspector option with the same name.
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Pre-defined values

Max is the maximum number of cards for the Kanban column. This value corresponds to
the Group Inspector option with the same name.
Level includes the optional categorization of the value in:
• Neutral (white circle)
• Normal (green dot)
• Warning (yellow triangle)
• Critical (red rectangle)
This categorization is only visible in the list of vales and has no planning impact; it is for the
planner’s information only.



The Allow free entry option is deactivated as the status fields use predefined and/or calculated values. Free entry is therefore not possible.
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